ISoP ISoP on Twitter | ACoP ACoP on Twitter | PAGE | WCoP | PAGANZ | PAGJa

What are the Browser Requirements?


#1

Discuss.go-isop.org is designed for the next 10 years of the Internet, so the minimum browser requirements are high:

  • Internet Explorer 10+ Google Chrome 24+ Firefox 14+ Safari 5.1+

It does not support Internet Explorer 9.